Just something I wanted to share. Today, I caught myself using two different naming conventions in the same code.
One is the camel-case style like Qt uses, and the other is the underscore style that STL and boost use.
It turned out that I use camel-case for everything except for when writing generic stuff like algorithms (to follow things like std::for_each, std::find_if) or special helper template classes.
For example kamd::util::for_each_assoc, model_insert (class that does RAII equivalent of beginInsertRows/endInsertRows).
Strangely enough, it feels natural. More natural than having names like qLowerBound, qBinaryFind…